WordPress

Erro ao atualizar Plugin no WordPress 4.2

Salve Salve, hoje vou mostrar pra você como resolver um problema que passei recentemente, fiz a atualização para o WordPress 4.2 e aparentemente tudo correu bem. Passado alguns dias fui fazer um update de um plugin e me deparei com um erro ao atualizar o Plugin.

Na página de plugins instalados é exibido a seguinte mensagem: Warning: printf() [function.printf]: Argument number must be greater than zero in wp-admin/includes/update.php on line 289

Esse erro, impossibilita você de atualizar qualquer plugin que tenha algum update disponível no seu WordPress, como eu gosto de manter meus plugins e CORE atualizados, fui atrás de uma solução.

Como ajustar Erro ao atualizar Plugin – WordPress 4.2


Eu não sou a favor de fazer alterações no CORE, mas infelizmente a única maneira que realmente funcionou foi alterando o arquivo update.php que fica no seguinte caminho /wp-admin/includes.

Abra o arquivo e na linha 289 (mesma linha da mensagem de erro), procure pelo código abaixo

PHP

printf( __( 'There is a new version of %1$s available. <a href="%2$s" title="%3$s">View version %4$s details</a> or <a href="%5$s">update now</a>.' ),
$plugin_name, 
esc_url( $details_url ), 
esc_attr( $plugin_name ), 
$r->new_version, wp_nonce_url( self_admin_url( 'update.php?action=upgrade-plugin&plugin=' ) . $file, 
'upgrade-plugin_' . $file ) );

E substitua pelo seguinte código.

printf( __( 'There is a new version of %1$s available. <a href="%2$s" title="%3$s">View version %4$s details</a>.' ), 
$plugin_name, 
esc_url( $details_url ), 
esc_attr( $plugin_name ), 
$r->new_version, 
wp_nonce_url( self_admin_url( 'update.php?action=upgrade-plugin&plugin=' ) . $file, 
'upgrade-plugin_' . $file ) );

Salve o arquivo e envie novamente para seu servidor. Agora volte no admin, atualize a página de Plugins instalados e pronto, a mensagem Warning: printf() [function.printf]: Argument number must be greater than zero in wp-admin/includes/update.php on line 289 não é mais exibida e você já pode atualizar seus plugins no WordPress 4.2.

Fonte: WordPress Fórum

E você, tem outra solução pro erro ao atualizar plugin? Deu certo pra você? Comente.

Se o post te ajudou curte a página, não custa nada e me incentiva a continuar escrevendo.
Posts recomendados
Comentários

    Envie seu comentário.

    Seu email não será publicado